M-Pesa STK and B2B issues
Incident Report for IntaSend
Resolved
Issue has been resolved and we are closely monitoring it. Sorry for any inconvenience caused.
Posted Mar 04, 2024 - 13:48 EAT
Investigating
From 9 am earlier today we have noticed intermittent failures on M-Pesa STK push and B2B request. This is a system issue from M-Pesa side. We are following up with the provider to have it resolved.
Posted Mar 04, 2024 - 11:30 EAT
This incident affected: Payments (M-Pesa Deposits).