Failures on M-Pesa B2B and C2B (STK Push)
Incident Report for IntaSend
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 23:09 EAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2024 - 22:39 EAT
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2024 - 20:46 EAT
Identified
Intermittent timeouts identified when connecting to the provider. We have communicated with the provider to have it resolved.
Posted Feb 13, 2024 - 19:56 EAT
This incident affected: Payments (M-Pesa B2C, M-Pesa Deposits).