Service downtime noted and our team is already working on it.
Incident Report for IntaSend
Resolved
This incident has been resolved. We are closely monitoring all the services. Sorry for any inconvenience it might have caused.
Posted Jul 03, 2021 - 09:57 EAT
Investigating
The website and card payments are affected
Posted Jul 03, 2021 - 09:23 EAT
This incident affected: Payments (Card Payments).