A fix has been implemented and we are monitoring the results.
Posted May 12, 2025 - 12:46 EAT
Identified
We are experiencing downtime with our M-PESA B2C and Pesalink channels. We are working with the partner to resolve the issue. We apologize for the inconveniences caused.
Posted May 12, 2025 - 10:45 EAT
This incident affects: Payments (M-Pesa B2C, Bank Payouts (PesaLink)).