M-PESA Downtime

Incident Report for IntaSend

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 12:29 EAT

Monitoring

M-PESA STK push has been restored. We're are monitoring the service to make sure it works as expected.
Posted Apr 04, 2025 - 16:36 EAT

Identified

We noted an issue with M-PESA STK Push. We are working with the provider to restore the service.
Posted Apr 04, 2025 - 16:17 EAT
This incident affected: Payments (M-Pesa Deposits).