M-Pesa disbursement timeout
Incident Report for IntaSend
Resolved
This incident has been resolved.
Posted Nov 04, 2021 - 12:46 EAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2021 - 12:39 EAT
Update
We are continuing to investigate this issue.
Posted Nov 04, 2021 - 11:41 EAT
Update
We are continuing to investigate this issue.
Posted Nov 04, 2021 - 11:34 EAT
Investigating
We have observed failures on M-Pesa disbursements - the failures are on Safaricom/M-Pesa side where we are unable to send requests.

We are already talking to them to have this resolved as soon as possible. Sorry for any inconvenience it might have caused.
Posted Nov 04, 2021 - 11:28 EAT
This incident affected: Payments (M-Pesa B2C, M-Pesa Deposits) and Wallet and Deposits (Direct Account Deposits).