MPESA C2B Downtime

Incident Report for IntaSend

Resolved

This incident has been resolved.
Posted May 11, 2025 - 19:36 EAT

Monitoring

All the services are back. We are monitoring the issue as we try and get to the root cause of it to avoid recurrence. Thank you for your continued patronage.
Posted May 10, 2025 - 09:15 EAT

Update

All the services are back. We are monitoring the issue as we try and get to the root cause of it to avoid recurrence. Thank you for your continued patronage.
Posted May 10, 2025 - 09:15 EAT

Investigating

We are experiencing degraded service with M-PESA C2B channel affecting M-PESA payment collections. We are working with the partner to resolve this issue.
Posted May 10, 2025 - 07:11 EAT
This incident affected: Payments (M-Pesa Deposits).